Sourceforge Logo

The new build system requires that you have a version 0.90 or greater of SCons. You will also need to have Python version 2.1 or greater installed. NOTE: These are only required for building the source code. You don't need them if you use the binary packages.

There are a number of libraries that LibKSD depends on to operate. Here is the list of required and optional dependencies for the latest release. NOTE: If items are marked optional, LibKSD will still compile, but you will lose the features those items provide. Also, some of the demos may not work if not all components are available.

Stable releases

We are still very early in LibKSD's development cycle. Many parts of the library change on a weekly and even daily basis as the design takes form. If this is a library you're interested in please be patient, or help contribute!

Developemental releases

WARNING: We provide no guarantee that any of the code here works. It will probably compile (depending on your environment), but it does contain bugs. This is provided that developers may preview this work and consider contributing. Do not use this code in a production environment. In fact, do not even use this code for a serious project because the APIs willchange.

Version 0.1.0-Pre2

Version 0.1.0-Pre1

Version 0.0.4

NOTE: To obtain copies of earlier versions please see the Source Forge project page.


The source is always available from CVS. See the cvs section on the project page for more information. Commits are made on a regular basis. This "bleeding edge" code is generally riddled with errors and may not (but probably will) compile.